星空软件

 找回密码
 立即注册
搜索

教大家写抖音作品评论id提取工具,批量提取用户的账号

星空软件 | 2021-10-5 12:05:43 | 显示全部楼层 |阅读模式
易语言
脚本名称: 抖音评论ID提取
脚本大小: 20 KB
开发平台: 易语言
是否开源: 开源版
功能介绍: 一键提取作品里面评论用户的ID

开发前

今天要教大家用易语言开发一款可以提取抖音作品上评论用户的ID,对抖音营销人员来说,这篇文章的干货是非常足的,其实你只要按照我说的要求去开发就能实现这么一个效果。难度其实真的不大。

我们就不借用按键精灵之类的脚本开发工具,感觉很不稳定,语言还可以哈,毕竟能实现多线程。需要那些工具呢:易语言精易模块精易web浏览器就足够了 。

需要的工具:

1.易语言
2.精易web浏览器
3.精易模块

开发教程

我们就不多废话了,直接进入开发模式吧,先用易语言创建一个新的程序,然后把该需要的组件都添加,如下图,我这边为了教程就提前弄好了。
截图202110051129195263.png

然后需要做的是把抖音作品的链接在易语言的精易web浏览器里面进行打开,解析源代码即可,先把链接导入到精易web里面,然后取浏览器的源码,然后我们就对源码进行一个后期文本处理,用正则其实效果挺好的。

.版本 2
.支持库 wke

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

精易Web浏览器1.浏览网页 (编辑框1.内容)

.子程序 __启动窗口_创建完毕

.子程序 _精易Web浏览器1_文档载入完毕
.参数 载入URL, 文本型
.参数 载入状态, 整数型
.参数 失败原因, 文本型

编辑框2.内容 = 编码_utf8到gb2312 (精易Web浏览器1.取网页源码 ())

上面的代码可以实现自动获取作品里面的源码,而源码就包括评论用户的ID、名称和评论内容等信息,我们为了节约大家的时间,这里就仅仅提供一个解析用户ID的教程,其他的就先不弄了,大家自己下去了脑补吧。
截图202110051148003409.png

检查源码后我们已经找到评论用户的ID了,然后通过正则把ID提取出来即可,正则代码为:author_id=([\s\S]*?)&,通过这个我们就可以提取出源码里面的所有ID数据,如下图

截图202110051156029802.png

然后我们把正则对接到易语言里面,看下最终的效果是如何

.版本 2

.子程序 _按钮2_被单击

正则_匹配批量 (编辑框2.内容)

.子程序 正则_匹配批量, 整数型, , 本子程序采用【精易编程助手】生成。成功返回匹配的数量,失败返回0。
.参数 源文本, 文本型, , 欲被匹配的文本
.局部变量 局_正则, 正则表达式类, , , 此类为精易模块里面的正则类,精易模块下载地址:http://ec.125.la/
.局部变量 局_匹配数, 整数型
.局部变量 局_计次, 整数型

.如果真 (局_正则.创建 (“author_id=([\s\S]*?)&”, 源文本, 假, 假, 真,真) = 假)
    信息框 (“正则创建失败,请检查正则表达式语句是否有误!”, #错误图标, )
    返回 (0)
.如果真结束
局_匹配数 = 局_正则.取匹配数量 ()
.如果真 (局_匹配数 = 0)
    信息框 (“匹配失败,请检检查正则语句是否有误,数量:0”, #错误图标, )
    返回 (0)
.如果真结束
.计次循环首 (局_匹配数, 局_计次)
    输出调试文本 (“匹配文本 ” + 到文本 (局_计次) + “ 中的子匹配文本 1:” + 局_正则.取子匹配文本 (局_计次, 1))
.计次循环尾 ()
返回 (局_匹配数)

截图202110051201529211.png

id已经在下方已经解析出来了,其实这个我们不一样用易语言写,用一般的采集工具都可以写出来,比如用后羿采集器,火车头采集器都可以实现这种效果的,好了下面就把源码的下载方式提供给大家。

文件名:抖音ID提取.e
已经过安全软件检测无毒,请您放心下载













上一篇:快手直播间抢拍脚本,抢货下单捡漏神器,安卓APK版!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全站声明|联系我们|小黑屋|星空软件

GMT+8, 2021-10-18 03:35 , Processed in 0.138229 second(s), 34 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.