星空软件

 找回密码
 立即注册

一款易语言取文件名称后缀的工具!附源码

 
简单350 | 2020-10-5 13:30:16 | 显示全部楼层 |阅读模式
易语言
名称(name): 星空软件取后缀工具 v1.1
大小: 8 KB
开发者: 易语言
是否开源: 开源版
功能介绍: 开发一款易语言取文件名后缀的工具!原理很简单,提供源码。
脚本介绍:
可以取指定文件的后缀名称,不管是任何格式的文件,都可以操作~开发原理也简单,用“倒找文本()”命令加“取文本右边()”命令结合实现的。
脚本功能:
1、一键取指定文件的后缀名称
2、一键读取文件全路径
下载地址:(源码)
取文件名后缀.e (3.7 KB, 下载次数: 15)
源代码:易语言
  1. .版本 2

  2. .程序集 窗口程序集_启动窗口

  3. .子程序 _按钮1_被单击

  4. 通用对话框1.打开 ()
  5. 编辑框1.内容 = 通用对话框1.文件名


  6. .子程序 _按钮2_被单击
  7. .局部变量 后缀, 文本型

  8. 后缀 = 取文本右边 (编辑框1.内容, 取文本长度 (编辑框1.内容) - 倒找文本 (编辑框1.内容, “\”, , 假))
  9. 编辑框2.内容 = 后缀
  10. 信息框 (“此文件、后缀名为:” + 后缀, 0, , )
复制代码
脚本截图:
截图202010051328193273.png
图1/程序界面

完整代码界面

完整代码界面

图2/完整代码界面




上一篇:抖音全自动发私信脚本,群发器下载
下一篇:识图点击脚本(可识别任意图片颜色)自动点击!
回复

使用道具 举报

David902 | 2020-10-5 13:31:28 | 显示全部楼层
谢谢楼主,成功解决了我的问题。
回复

使用道具 举报

 楼主| 简单350 | 2020-10-5 13:31:36 | 显示全部楼层
这个教程写的很详细,感谢
回复

使用道具 举报

小妖花满楼满fx | 2020-10-5 13:32:59 | 显示全部楼层
解决了我好多天都没想通的编程难题,原来这么简单,一个取文本长度减过倒找文本即可实现。。。是我太笨,还是楼主太聪明?
回复

使用道具 举报

老橡树1 | 2020-10-5 13:33:52 | 显示全部楼层
代码看不懂的朋友,下载上面提供的源码,慢慢研究。
回复

使用道具 举报

2712622412 | 2022-12-13 08:11:29 | 显示全部楼层
全都是假的啊,根本下载不了
回复

使用道具 举报

alisonef7 | 2024-5-31 14:02:49 | 显示全部楼层
It s just lunch matchmaking services for professionals
https://my-hot-stepmom-tenga.fetish-matters.net/?mckenna-kaia
回复

使用道具 举报

stephanieej9 | 2024-5-31 20:32:59 | 显示全部楼层
Goodporn to free porn videos and full hd sex movies
https://petite-brunette-taxi.fetish-matters.net/?abbigail-tanya
回复

使用道具 举报

elsienl3 | 2024-6-1 03:47:38 | 显示全部楼层
Taboo japan tube best gyno porn tubes streaming asian porn
https://diaper-pee-fuxers.fetish-matters.com/?josie-rachael
回复

使用道具 举报

theodoreph2 | 2024-6-1 04:52:38 | 显示全部楼层
How do i findwork credentials user name and password
https://throbbing-transgender-girl.fetish-matters.net/?maegan-sylvia
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

全站声明【必看】|小黑屋|新库软件 |网站地图

GMT+8, 2024-6-22 10:45 , Processed in 0.073260 second(s), 33 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.