星空软件

 找回密码
 立即注册

采集贴吧手机号、邮箱软件(附易源码)

发表于 2020-6-10 22:41:38 | 显示全部楼层 |阅读模式
易语言
脚本名称: 百度贴吧手机号采集器
脚本大小: 721 KB
开发平台: 易语言
是否开源: 开源版
功能介绍: 易语言版贴吧手机号、邮箱采集器,附送源码哦
脚本介绍:
这是一款易语言开发的贴吧手机号、邮箱采集软件,但是只能对指定贴吧进行采集哦,你可以手动输入一些吧,程序会自动访问这些吧,然后自动采集帖子以及帖子所包含的手机号、邮箱哦,功能非常实用,而且还是开源版的,下面我们会详细的介绍这款脚本哦。
特色功能:
1、支持设置采集页数
2、自定义采集时间限制
3、支持手机号采集、邮箱采集
4、实时显示所采集数据
5、自定义指定吧采集(输入指定贴吧名即可)
下载地址:
易语言百度贴吧采集器.rar
附件大小:720.96 KB
下载次数:23




上一篇:头条号自动发布工具!支持文章采集
下一篇:易语言正则取IMG src图片地址!可批量(通用)
回复

使用道具 举报

发表于 2020-6-10 22:42:33 | 显示全部楼层
是不是易语言版的贴吧爬虫程序呢???
回复

使用道具 举报

发表于 2020-6-10 22:44:30 | 显示全部楼层
这款工具的源码我也有,现在把源代码直接发给大家把!
  1. <b><font color="#ff0000">窗口程序集代码:</font></b>
  2. .版本 2
  3. .支持库 internet
  4. .支持库 spec
  5. .支持库 RegEx
  6. .支持库 iext
  7. .支持库 eAPI
  8. .支持库 EThread

  9. .程序集 窗口程序集_启动窗口
  10. .程序集变量 time, 整数型

  11. .子程序 子程序1

  12. 加载皮肤 (33)

  13. .子程序 __启动窗口_创建完毕, , , 易语言交流群:736895457
  14. .局部变量 返回文本, 文本型, , , 易语言交流群:736895457
  15. .局部变量 版本号, 文本型, , , 易语言交流群:736895457

  16. time = 5 × 60 × 1000
  17. 时钟1.时钟周期 = 1000
  18. 加载皮肤 (33)
  19. 返回文本 = 编码_URL解码 (到文本 (HTTP读文件 (“https://blog.csdn.net/u010130776/article/details/78528504”)), 真)

  20. 版本号 = 文本_取出中间文本 (返回文本, #软件控制前, #软件控制后)

  21. 调试输出 (版本号)
  22. .如果 (版本号 = “1.0”)

  23. .否则

  24. .如果结束

  25. .如果 (版本号 = “2.0”)
  26.     _启动窗口.标题 = “百度贴吧手机号采集器  By:竹子  QQ:82109531”
  27.     编辑框4.内容 = 编辑框4.内容 + #换行符 + “软件暂时只写了导出烤鱼的数据,对软件对易语言感兴趣的可以加Q群:736895457共同学习”
  28. .否则

  29. .如果结束




  30. .如果 (版本号 = “3.0”)
  31.     信息框 (“版本已经更新,请联系QQ:82109531”, 0, , )
  32.     销毁 ()

  33. .否则

  34. .如果结束




  35. .子程序 获取location, , , 易语言交流群:736895457
  36. .局部变量 返回文本, 文本型
  37. .局部变量 返回协议头, 文本型
  38. .局部变量 location, 文本型
  39. .局部变量 地址, 文本型

  40. 地址 = 编码_URL编码 (编辑框2.内容, , 真)
  41. 调试输出 (“https://tieba.baidu.com/f?ie=utf-8&kw=” + 地址 + “”)
  42. 获取 (“https://tieba.baidu.com/f?ie=utf-8&kw=” + 地址 + “”)

  43. .子程序 获取, , , 易语言交流群:736895457
  44. .参数 location, 文本型, , 易语言交流群:736895457
  45. .局部变量 索引, 整数型, , , 易语言交流群:736895457
  46. .局部变量 返回文本, 文本型, , , 易语言交流群:736895457
  47. .局部变量 正则, 正则表达式类, , , 易语言交流群:736895457
  48. .局部变量 i, 整数型, , , 易语言交流群:736895457
  49. .局部变量 正则1, 正则表达式类, , , 易语言交流群:736895457
  50. .局部变量 正则2, 正则表达式类, , , 易语言交流群:736895457
  51. .局部变量 正则3, 正则表达式, , , 易语言交流群:736895457
  52. .局部变量 正则4, 正则表达式类, , , 易语言交流群:736895457
  53. .局部变量 正则5, 正则表达式类, , , 易语言交流群:736895457
  54. .局部变量 手机号, 文本型, , , 易语言交流群:736895457
  55. .局部变量 s, 搜索结果, , "0", 易语言交流群:736895457
  56. .局部变量 测试, 文本型, , , 易语言交流群:736895457
  57. .局部变量 文本, 文本型, , , 易语言交流群:736895457
  58. .局部变量 帖子内容, 文本型, , "0", 易语言交流群:736895457
  59. .局部变量 h, 整数型, , , 易语言交流群:736895457
  60. .局部变量 l, 整数型, , , 易语言交流群:736895457
  61. .局部变量 页数, 文本型, , , 易语言交流群:736895457
  62. .局部变量 k, 整数型, , , 易语言交流群:736895457
  63. .局部变量 g, 整数型, 静态, , 易语言交流群:736895457
  64. .局部变量 v, 搜索结果, , "0", 易语言交流群:736895457
  65. .局部变量 当前时间, 日期时间型, , , 易语言交流群:736895457
  66. .局部变量 时间间隔, 整数型, , , 易语言交流群:736895457
  67. .局部变量 读取的内容, 文本型, , , 易语言交流群:736895457

  68. 超级列表框1.全部删除 ()
  69. .计次循环首 (到整数 (编辑框1.内容), h)
  70.     返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (location + “&pn=” + 到文本 ((h - 1) × 50) + “red_tag=f1703066392”, 0, “”, “BAIDUID=85A89F48EE6532CA39C26EFF6961BDB3:FG=1; BIDUPSID=85A89F48EE6532CA39C26EFF6961BDB3; PSTM=1521164404; TIEBAUID=62025b4bb29c595fec1db9fd; TIEBA_USERTYPE=2fec9c75aa6798c5ffe9dfec; H_PS_PSSID=1432_21089_20928; BDRCVFR[feWj1Vr5u3D]=I67x6TjHwwYf0; PSINO=5; BDORZ=B490B5EBF6F3CD402E515D22BCDA1598; baidu_broswer_setup_zhuzi839=0; wise_device=0; bdshare_firstime=1525656132069; FP_UID=3db1ca4c9db74ad69593693692f6cf00; Hm_lvt_98b9d8c2fd6608d564bf2ac2ae642948=1525655874,1525657696; Hm_lpvt_98b9d8c2fd6608d564bf2ac2ae642948=1525657696”, , #UA)))
  71.     调试输出 (location + “&pn=” + 到文本 ((h - 1) × 50) + “&red_tag=f1703066392”)
  72.     调试输出 (返回文本)
  73.     写到文件 (取运行目录 () + “\log.txt”, 到字节集 (到文本 (读入文件 (取运行目录 () + “\log.txt”)) + 返回文本 + #换行符))
  74.     正则.创建 (#正则采集, 返回文本, 真, 真, 真)
  75.     正则1.创建 (#采集手机号正则, 返回文本, 真, 真, 真)
  76.     .计次循环首 (正则.取匹配数量 (), i)

  77.         索引 = 超级列表框1.插入表项 (超级列表框1.取表项数 (), 到文本 (超级列表框1.取表项数 () + 1), , , , )
  78.         超级列表框1.置标题 (索引, 1, 正则.取子匹配文本 (i, 2))
  79.         超级列表框1.置标题 (索引, 3, 正则.取子匹配文本 (i, 1))
  80.         超级列表框1.置标题 (索引, 2, 正则1.取子匹配文本 (i, 1))
  81.         超级列表框1.保证显示 (索引)






  82.         返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“https://tieba.baidu.com” + 正则.取子匹配文本 (i, 1), 0, “”, “BAIDUID=85A89F48EE6532CA39C26EFF6961BDB3:FG=1; BIDUPSID=85A89F48EE6532CA39C26EFF6961BDB3; PSTM=1521164404; TIEBAUID=62025b4bb29c595fec1db9fd; TIEBA_USERTYPE=2fec9c75aa6798c5ffe9dfec; BDORZ=B490B5EBF6F3CD402E515D22BCDA1598; bdshare_firstime=1525656132069; H_PS_PSSID=1432_21089_20928; PSINO=5; Hm_lvt_98b9d8c2fd6608d564bf2ac2ae642948=1525655874,1525657696,1525672102; wise_device=0; FP_UID=3db1ca4c9db74ad69593693692f6cf00; Hm_lpvt_98b9d8c2fd6608d564bf2ac2ae642948=1525674022”, , “User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36”)))

  83.         ' 返回帖子具体内容   共几页  找到多少手机号
  84.         正则4.创建 (#页数采集正则, 返回文本, 真, 真, 真)
  85.         页数 = 正则4.取子匹配文本 (i, 1)
  86.         调试输出 (“有” + 页数 + “页”)
  87.         ' 有几页就循环几次
  88.         .计次循环首 (到整数 (页数) + 1, k)


  89.             返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“https://tieba.baidu.com” + 正则.取子匹配文本 (i, 1) + “?pn=” + 到文本 (k) + “”, 0, “”, “BAIDUID=85A89F48EE6532CA39C26EFF6961BDB3:FG=1; BIDUPSID=85A89F48EE6532CA39C26EFF6961BDB3; PSTM=1521164404; TIEBAUID=62025b4bb29c595fec1db9fd; TIEBA_USERTYPE=2fec9c75aa6798c5ffe9dfec; BDORZ=B490B5EBF6F3CD402E515D22BCDA1598; bdshare_firstime=1525656132069; H_PS_PSSID=1432_21089_20928; PSINO=5; Hm_lvt_98b9d8c2fd6608d564bf2ac2ae642948=1525655874,1525657696,1525672102; wise_device=0; FP_UID=3db1ca4c9db74ad69593693692f6cf00; Hm_lpvt_98b9d8c2fd6608d564bf2ac2ae642948=1525674022”, , “User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36”)))

  90.             正则2.创建 (#采集规则, 返回文本, 真, 真, 真)
  91.             正则5.创建 (#时间正则, 返回文本, 真, 真, 真)
  92.             调试输出 (正则2.取子匹配文本 (i, 1))
  93.             调试输出 (正则5.取子匹配文本 (i, 1))

  94.             .如果 (正则2.取匹配数量 () = 0)
  95.                 正则2.创建 (#采集规则1, 返回文本, 真, 真, 真)
  96.             .否则

  97.             .如果结束

  98.             .如果 (正则5.取匹配数量 () = 0)
  99.                 正则5.创建 (#时间规则1, 返回文本, 真, 真, 真)
  100.             .否则

  101.             .如果结束

  102.             调试输出 (正则2.取子匹配文本 (i, 1))
  103.             调试输出 (正则5.取子匹配文本 (i, 1))



  104.             .计次循环首 (正则2.取匹配数量 (), i)

  105.                 .如果 (单选框1.选中 = 真)
  106.                     正则3.创建 (“[1-9][0-9]{10}”, )
  107.                 .否则
  108.                     正则3.创建 (“[a-zA-Z0-9_]+[@#]\w+([-.]\w+)*\.\w+([-.]\w+)*[a-zA-Z]”, )
  109.                 .如果结束



  110.                 s = 正则3.搜索全部 (正则2.取子匹配文本 (i, 1))


  111.                 .计次循环首 (取数组成员数 (s), l)

  112.                     ' 手机号去重复
  113.                     读取的内容 = 到文本 (读入文件 (取运行目录 () + “\采集到的数据.txt”))
  114.                     调试输出 (“读取的内容” + 读取的内容)
  115.                     调试输出 (“代添加的手机号” + s [l].取匹配文本 (正则2.取子匹配文本 (i, 1), ))
  116.                     .如果 (寻找文本 (读取的内容, s [l].取匹配文本 (正则2.取子匹配文本 (i, 1), ), , 假) ≠ -1)
  117.                         调试输出 (“重复的手机号”)
  118.                         调试输出 (“重复”)
  119.                     .否则
  120.                         写到文件 (取运行目录 () + “\采集到的数据.txt”, 到字节集 (到文本 (读入文件 (取运行目录 () + “\采集到的数据.txt”)) + s [l].取匹配文本 (正则2.取子匹配文本 (i, 1), ) + #换行符))
  121.                         调试输出 (“不重复”)
  122.                     .如果结束





  123.                     g = g + 1
  124.                     当前时间 = 取现行时间 ()

  125.                     时间间隔 = 取时间间隔 (当前时间, 到时间 (正则5.取子匹配文本 (i, 1)), #秒)
  126.                     .如果 (时间间隔 < 到整数 (编辑框3.内容))


  127.                         ' 手机号去重复
  128.                         .如果 (寻找文本 (读取的内容, s [l].取匹配文本 (正则2.取子匹配文本 (i, 1), ), , 假) ≠ -1)
  129.                             调试输出 (“重复的手机号”)
  130.                         .否则
  131.                             写到文件 (取运行目录 () + “\采集到的限制数据.txt”, 到字节集 (到文本 (读入文件 (取运行目录 () + “\采集到的限制数据.txt”)) + s [l].取匹配文本 (正则2.取子匹配文本 (i, 1), ) + #换行符))
  132.                         .如果结束



  133.                     .否则

  134.                     .如果结束


  135.                 .计次循环尾 ()
  136.                 超级列表框1.置标题 (索引, 4, “采集到数据” + 到文本 (g) + “个”)
  137.             .计次循环尾 ()






  138.         .计次循环尾 ()




  139.         g = 0


  140.     .计次循环尾 ()












  141. .计次循环尾 ()




  142. .子程序 _超级列表框1_被双击, 逻辑型, , 易语言交流群:736895457
  143. .参数 横向位置, 整数型, , 易语言交流群:736895457
  144. .参数 纵向位置, 整数型, , 易语言交流群:736895457
  145. .参数 功能键状态, 整数型, , 易语言交流群:736895457

  146. 打开指定网址 (“https://tieba.baidu.com” + 超级列表框1.取标题 (超级列表框1.现行选中项, 3))
  147. 调试输出 (超级列表框1.取标题 (超级列表框1.现行选中项, 3))

  148. .子程序 _按钮4_被单击, , , 易语言交流群:736895457

  149. 启动线程 (&获取location, , )


  150. .子程序 _时钟1_周期事件, , , 易语言交流群:736895457

  151. time = time - 1000
  152. 标签1.标题 = “软件还有” + 到文本 (time ÷ 1000) + “秒关闭”
  153. .如果 (time ≤ 0)
  154.     销毁 ()
  155. .否则

  156. .如果结束

复制代码
  1. <b>常亮:</b>
  2. .版本 2

  3. .常量 正则采集, "<文本长度: 81>"
  4. .常量 UA, "<文本长度: 121>"
  5. .常量 获取locationUA, "<文本长度: 261>"
  6. .常量 常量1, "<文本长度: 50>"
  7. .常量 常量2, "<文本长度: 51>"
  8. .常量 采集手机号正则, "<文本长度: 23>"
  9. .常量 采集规则, "<文本长度: 56>"
  10. .常量 采集规则1, "<文本长度: 47>"
  11. .常量 页数采集正则, "<文本长度: 40>"
  12. .常量 时间正则, "<文本长度: 27>"
  13. .常量 时间规则1, "<文本长度: 36>"
  14. .常量 软件控制前, "<文本长度: 47>"
  15. .常量 软件控制后, "<文本长度: 4>"
复制代码


回复

使用道具 举报

发表于 2020-6-10 22:45:20 | 显示全部楼层
楼上你说你无聊不???发代码有啥用,直接发e源码呀,真是牛X啊你
回复

使用道具 举报

发表于 2020-6-10 22:45:54 | 显示全部楼层
下载学习学习,最近在接触易语言,是不是和POST有关系?
回复

使用道具 举报

发表于 2020-6-10 22:47:02 | 显示全部楼层
这款工具假如能用的话,那价值就高了,可以采集手机号,就相当于采集微信ID一样。
回复

使用道具 举报

发表于 2020-6-10 22:47:45 | 显示全部楼层
易语言版的贴吧采集器,少见,而且还有源码,有技术条件的二次开发。
回复

使用道具 举报

发表于 2020-6-10 22:49:07 | 显示全部楼层
精易论坛上这种源码很多,好不好用就不清楚了,源码貌似被加密,密码是:a123456
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-8-10 06:50 , Processed in 0.098551 second(s), 30 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

返回顶部 返回列表