星空软件

 找回密码
 立即注册

微信wxid二维码生成器!一键转换

发表于 2020-5-21 16:36:13 | 显示全部楼层 |阅读模式
易语言
工具(脚本)名称: wxid转二维码
工具(脚本)大小: 10 KB
开发平台: 易语言
工具(脚本)类型: 其他
功能简介: -
今天给大家分享一款易语言版的WXID生成器吧,你只需要把WXID输入到这个软件,就能一键生成一个二维码,是一个实用的WXID转二维码软件,软件是用易语言开发的,下面我们将会提供这款软件的开发原理和开发步骤,对接了第三方的API实现的。
开发步骤:
1、先做好界面吧
222.png
2、网上搜“二维码开放平台”,随便找一个接口
222.png
3、双击“一键生成”按钮,并写入如下代码
333.png
4、最后我们运行程序,输入wxid数据,发现可以成功返回二维码图。

转换二维码

转换二维码

完整源码:
  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口

  4. .子程序 _按钮1_被单击
  5. .局部变量 API, 文本型
  6. .局部变量 返回的二维码, 字节集

  7. API = “http://qr.liantu.com/api.php?text=” + 编辑框1.内容
  8. 返回的二维码 = 网页_访问 (API, 0, )
  9. 调试输出 (返回的二维码)
  10. 图片框1.图片 = 返回的二维码
复制代码
源码下载地址:
wxid转二维码.e
附件大小:842.9 KB
下载次数:312




上一篇:解析!微信群二维码采集器原理
下一篇:微信强制隐身加群软件的原理!及提供下载
回复

使用道具 举报

 楼主| 发表于 2020-5-21 16:37:33 | 显示全部楼层
其实通过这种方法我们就能用易语言开发一款wxid转二维码的软件,开发原理也是相当简单的,二维码的生成主要由API进行返回,并由画板显示。
回复

使用道具 举报

 楼主| 发表于 2020-5-21 16:38:04 | 显示全部楼层
如果大家觉得难的话,可以直接把我提供的源代码复制到你的程序里面,直接运行就行了。
回复

使用道具 举报

 楼主| 发表于 2020-5-21 16:39:42 | 显示全部楼层
WXID生成二维码就这么简单,网上找一个免费的二维码生成API,然后加入到你的易程序里面,用网页访问进行返回数据,返回的数据再用画板进行显示,就这么简单。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-5-29 21:45 , Processed in 0.147635 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表