星空软件

 找回密码
 立即注册

简单用易语言打造属于自己的聊天软件!

发表于 2020-3-23 10:07:46 | 显示全部楼层 |阅读模式
易语言
工具(脚本)名称: 易语言聊天软件
工具(脚本)大小: 5 KB
开发平台: 易语言
工具(脚本)类型:
功能简介: 其实利用易语言功能还是比较强大的,一般的聊天软件其实利用易语言也是可以开发的,今天我们就教大家利用易语言的服务器、客户端组件开发一款简单的聊天软件吧。
其实利用易语言功能还是比较强大的,一般的聊天软件其实利用易语言也是可以开发的,今天我们就教大家利用易语言的服务器、客户端组件开发一款简单的聊天软件吧,虽然说这个软件的开发步骤和原理很简单,但是我们的目的就是让大家了解易语言功能组件的一些用法。
需要的工具:
1、易语言
2、客户、服务器组件
操作步骤:
1、我们先设计客户端的成功界面吧,这边为了给大家做演示,程序界面早已经设计好的。
1.png
2、完了查看一下本地IP,再把客户端连接服务器端的代码写上去。
2.png
3、然后我们写客户端发送数据和接受数据的代码!
3.png
4、完了设计服务器端的界面,然后端口设置成和客户端一样的。
2.png
5、以下代码包括了服务器端的取回客户、发送数据、客户进入,向客户端发送指定数据等所有事件代码和其他相关代码。
3.png
4、完了我们测试一下客户端连接服务器是否成功!当我们点击客户端的连接服务器按钮后,服务器端的程序成功返回连接成功状态。
2.png
5、而且服务器端和客户端也可以正常进行通信,看下图。

通讯

通讯

客户端源码:
[ecode=4].版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

客户1.连接 (“192.168.43.33”, 1995)


.子程序 _客户1_数据到达

编辑框1.内容 = 到文本 (客户1.取回数据 ())


.子程序 _按钮2_被单击

客户1.发送数据 (编辑框2.内容)

[/ecode]
服务器端源码:
[ecode=4].版本 2

.程序集 窗口程序集_启动窗口

.子程序 _服务器1_客户进入

信息框 (“有客户端连接”, 0, , )
客户地址 = 服务器1.取回客户 ()

.子程序 _服务器1_客户离开

信息框 (“有客户端断开连接”, 0, , )

.子程序 _服务器1_数据到达

编辑框1.内容 = 到文本 (服务器1.取回数据 ())


.子程序 _按钮1_被单击

服务器1.发送数据 (客户地址, 编辑框2.内容, 5000)

[/ecode]




上一篇:利用按键精灵能制作微信机器人脚本吗?方法
下一篇:抖音63数据提取还原工具,支持导入和导出!
回复

使用道具 举报

 楼主| 发表于 2020-3-23 12:46:35 | 显示全部楼层
利用易语言开发这么一款软件,总共代码不超过20行,但是却能实现相互连接,发送消息等功能,这就是易语言的强大之处。
回复

使用道具 举报

 楼主| 发表于 2020-3-23 12:48:02 | 显示全部楼层
当然这个教程里面其实所涉及的知识点也比较少,最多的就是“连接()”,“取回客户()”,“取回数据()”这几个功能了。。。
回复

使用道具 举报

 楼主| 发表于 2020-3-23 12:48:42 | 显示全部楼层
那么你可以利用这篇文章所讲到的知识点来开发一个功能更强大的聊天软件,希望对你有帮助哈。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-3 03:44 , Processed in 0.145118 second(s), 30 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表