星空软件

 找回密码
 立即注册

精易WEB浏览器框内执行js代码的方式!

原创
发表于 2020-3-20 14:40:36 | 显示全部楼层 |阅读模式
微信资讯
文章来源: xkrj5
作者: 万花
属性: 原创
其实利用精易WEB浏览器执行js代码是比较方便的,可以直接在浏览器框内的网页运行,能直接看到JS的运行效果,在没有精易WEB浏览器框之前,我们在易语言运行JS都是直接调用系统的脚本组件来完成,但是缺点也是显而易见的,没办法直接在网页看到运行效果,只能返回JS的运行值,那么今天我们这篇文章的目的就是利用精易WEB浏览器框来给大家实现一下JS的运行方法吧。
需要用到的工具:
1、易语言
2、精易WEB浏览器框
操作方法:
1、我们需要在当前程序界面拖动一个精易WEB浏览器框!下图所示,包括编辑框,按钮等。
2.png
2、双击启动窗口,完了我们需要加入如下代码,在精易浏览器框里面打开一个网页。
2.png
3、完了我们配置一下关于精易浏览器执行JS代码的一些参数命令。
3.png
4、最后我们点击按钮执行一下某条JS命令,发现是可以成功执行的哈。

执行效果

执行效果


完整的易语言源代码:
[ecode=2].版本 2
.支持库 wke

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

精易Web浏览器1.浏览网页 (“www.xkrj5.com”)


.子程序 _按钮1_被单击
.局部变量 js, Javascript
.局部变量 wv, 整数型

wv = 精易Web浏览器1.取WebView ()
js.运行JS_值对象 (wv, 编辑框1.内容)[/ecode]
最后补充点:
其实某些朋友可能不知道精易WEB浏览器是什么,又如何下载,那么我们不废话,直接在百度搜“精易WEB浏览器框”就能找到,或者点击下方链接下载也可以,我们已经给大家打包上传到百度网盘了,免费下载使用哈。
精易WEB浏览器下载地址:
链接: https://pan.baidu.com/s/15DeXefavZzoB_5JvEK9x8w 提取码: 6izq 复制这段内容后打开百度网盘手机App,操作更方便哦





上一篇:后羿采集器采集百度相关词的操作教程
下一篇:闲鱼引流到淘宝什么方式最好?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-5 14:00 , Processed in 0.146431 second(s), 42 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表