星空软件

 找回密码
 立即注册

易语言通过进程名获取指定进程的句柄!

发表于 2020-3-12 12:56:25 | 显示全部楼层 |阅读模式
按键精灵
工具(脚本)名称: 易语言进程
工具(脚本)大小: 10 KB
开发平台: 易语言
工具(脚本)类型: 生活工作
功能简介: -
今天我们要给大家带来的干货是!利用易语言枚举指定的进程名,并获取指定进程的句柄号!是不是很想学呢?其实这样的教程网上有很多,但是星空软件网的小编觉得,网上的大部分此类教程都是调用一些DLL文件的API实现的,没有任何的学习价值,对于新手来说作用不大,最好是直接通过原生的代码能开发是最好的对吧,废话不多说直接操作。
需要的工具:
1、易语言
2、精易模块V8
开发原理图:
原里.png
其实我们下面要实现的功能原理大概像上图一样,我建议你先看下这个原理图,再继续往下看,这样的话好理解一下。。。
操作步骤:
1、我们打卡易语言,然后设计一下软件的整体框架,尽管很难看。
接码.png
2、点击枚举此进程,然后写入如下代码,代码功能是获取系统所以的进程列表,然后枚举编辑框内指定的进程名。
枚举.png
3、最后我们来一下结束指定进程的命令。
结束.png
整个程序的源代码:
[ecode=4].版本 2
.支持库 eAPI

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 进程列表, 进程信息, , "0"
.局部变量 i, 整数型

进程列表 = 取系统进程列表 ()
.计次循环首 (取数组成员数 (进程列表), i)
    .判断开始 (进程列表 .进程名称 = 编辑框1.内容)
        编辑框2.内容 = 到文本 (进程列表 .进程标识符)
        i = 0
    .默认

    .判断结束

.计次循环尾 ()

.子程序 _按钮2_被单击

进程_结束 (到整数 (编辑框2.内容))

[/ecode]
最后咋们看下程序的运行效果!当我们点击枚举按钮后,果然在另一个编辑框出现了此进程的句柄号。

句柄

句柄

有了句柄号,我们就可以通过一系列的名称去操作句柄所对应的窗口程度了!自己脑补哈。




上一篇:易语言开发淘宝客机器人,思路分析!有源码
下一篇:利用按键精灵能制作微信机器人脚本吗?方法
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-4 02:05 , Processed in 0.142183 second(s), 31 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表