星空软件

 找回密码
 立即注册

易语言开发宝宝取名字的软件!非常实用

发表于 2020-2-20 18:57:49 | 显示全部楼层 |阅读模式
易语言
工具(脚本)名称: 宝宝qum
工具(脚本)大小: 5 KB
开发平台: 易语言
工具(脚本)类型: 生活工作
功能简介: 易语言是我们国产的一款面向对象的中文可视化编程工具,易语言改变了国人的编程门槛,就算是上过小学的人就能用易语言开发功能强大的电脑程序,我们今天是教大家用易语言开发一个宝宝起名字的软件,希望大家喜欢
易语言是我们国产的一款面向对象的中文可视化编程工具,易语言改变了国人的编程门槛,就算是上过小学的人就能用易语言开发功能强大的电脑程序,我们今天是教大家用易语言开发一个宝宝起名字的软件,希望大家喜欢。
其实网上有很多起名字的软件,但是那些软件或许对有些人并没有解决取名需求,那么最好的解决办法是自己开发一个,功能自己设定就行了对吧,友情提示一下,网上哪些起名软件都是要钱的价格还不菲,尤其是某宝取名,其实他们用的都是网上的一些起名软件,根本划不来,那么如何用易语言开发一款宝宝起名软件呢,很简单,请看下面的操作步骤。
需要应用的工具:
一:易语言
二:精易模块
操作步骤:
1、打开易语言,新建一个程序窗口,然后拖入两个编辑框,一个按钮。
1.png
2、双击按钮1写入如下代码,把编辑框1内所有的姓氏存入到数组变量里面。
2.png
3、然后再写一个取随机数的函数,这样就可以随机取出数组里面的姓氏文本了。
3.png
4、接下来再写一个取随机汉子的函数。
3.png
5、最后我们需要把两个随机变量组合一下就实现起名字的功能效果啦!

随机名

随机名

完整的易语言代码:
[ecode=1].版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 姓氏, 文本型, , "0"
.局部变量 随机姓, 文本型
.局部变量 随机汉子, 文本型

姓氏 = 分割文本 (编辑框1.内容, #换行符, )
随机姓 = 姓氏 [取随机数 (1, 取数组成员数 (姓氏))]
调试输出 (随机姓)
随机汉子 = 文本_取随机汉字 (2)
调试输出 (随机汉子)
编辑框2.内容 = 随机姓 + 随机汉子[/ecode]
案例源代码下载:
取名.rar
附件大小:208.1 KB
下载次数:7




上一篇:易语言写百度页面链接提交和推送功能
下一篇:易语言取出编辑框里面指定的行内容
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-4 04:12 , Processed in 0.149895 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表