星空软件

 找回密码
 立即注册

易语言计次循环网页置标题怎么弄?

发表于 2020-2-9 13:11:22 | 显示全部楼层 |阅读模式
易语言
工具(脚本)名称: 计次循环
工具(脚本)大小: 10 KB
开发平台: 易语言
工具(脚本)类型: 其他
功能简介: 易语言的计次计次循环首这个命令函数相信大家都知道吧,我们需要给这个函数给定一个要循环的次数,就可以让程序循环执行。
易语言的计次计次循环首这个命令函数相信大家都知道吧,我们需要给这个函数给定一个要循环的次数,就可以让程序循环执行,这个函数经常用来进行操作一些循环的执行过程,比如我们今天需要利用这个函数的功能进行循环给网页文本框置标题,具体怎么操作呢?请看下面演示。
网页测试页面:http://www.xkrj5.com/member.php?mod=register
需要用到的工具:
1、精易WEB浏览器。
2、易语言开发工具
计次循环首命令详解:
调用格式: 〈无返回值〉 计次循环首 (整数型 循环次数,[整数型变量 已循环次数记录变量])
操作步骤:
1、我们需要新建一个程序窗口,然后再窗口拖动一个精易WEB浏览器组件和一个编辑框组件和一个按钮组件。
QQ截图20200209130043.png
2、我们双击按钮开始写代码。
2.png
3、我们在代码编辑框输入如下代码段,代码讲解请看其注释。[ecode=1].版本 2
.支持库 wke
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 填表, WKE_填表
.局部变量 web, 整数型
.局部变量 i, 整数型

web = 精易Web浏览器1.取WebView ()  ' 获取浏览器的View值到变量web里面
.计次循环首 (4, i)  ' 计次循环命令开始,并执行四次,把执行过程次数记录到变量I里面。
    编辑框1.内容 = 到文本 (取随机数 (1, 99999))  ' 编辑框1的内容等于一个随机数
    填表.表单_Input写属性 (web, #填表模式_精易模块, “id==HjJd12”, 1, “value”, 编辑框1.内容)  ' 通过精易WEB浏览器的填表功能实现文本框填表
    延迟 (2000)  ' 延迟执行两秒,1000毫秒就是1秒。

.计次循环尾 ()  ' 计次循环结束

.子程序 __启动窗口_创建完毕

精易Web浏览器1.浏览网页 (“http://www.xkrj5.com/member.php?mod=register”)  ' 当打开程序窗口既执行这条命令。[/ecode]
5、通过这样就能实现自动给网页文本框置标题了,很简单吧?自己动手做一做效果更棒。

测试

测试

精易WEB浏览器下载地址:
https://pan.baidu.com/s/1Yc__zVNCqu0u2YgSTfW8Rw   密码:2e3u  
案例脚本下载:
案例.rar
附件大小:1.6 KB
下载次数:0




上一篇:易语言获取QQ群好友列表,附bkn算法源码
下一篇:精易web浏览器设置cookie和取COOKie教程
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-5 15:22 , Processed in 0.121594 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表