星空软件

 找回密码
 立即注册

易语言Discuz3.4登陆加发私信工具,附源码

发表于 2020-1-21 19:05:26 | 显示全部楼层 |阅读模式
按键精灵
工具(脚本)名称: 易语言dz3.4发私信工具兼容3.2版
工具(脚本)大小: 13 KB
开发平台: 易语言
工具(脚本)类型: 其他
功能简介: 今天给大家分享一款易语言DZ3.4版的登陆器,支持发送私信功能,虽然说实现方法很简单,但是非常实用,为什么这么说呢?
今天给大家分享一款易语言DZ3.4版的登陆器,支持发送私信功能,虽然说实现方法很简单,但是非常实用,为什么这么说呢?因为小编发现了在网上有很多易语言DZ登陆器,或私信工具,但是大部分用的都是一些乱七八糟的模块,且不带源码,那样的工具我们下载了根本没一点作用和没有研究价值,而且大部分网上这样的工具下载来都是没法用,因为他们程序对接的DZ版本太低,网站一升级程序和代码都作废掉了,而且网上这一类的开发教程拿到现在也是没法用,因为DZ一直在升级,哪些教程文档都是几年前的东西,你觉得拿到现在可行吗?所以小编今天就给大家分享一款易语言开发dZ最新3.4版的登陆器和发帖器,想学习的请继续往下看。
需要的工具:
1、精易模块
2、易语言
3、精易编程助手
开发步骤:
废话我们不多讲,直接把具体的功能代码和源码发给大家吧!慢慢研究。
程序源代码:
[ecode=1].版本 2
.支持库 eAPI
.支持库 internet
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

打开指定网址 (“http://www.xkrj5.com”)


.子程序 _按钮1_被单击
.局部变量 数据, 文本型
.局部变量 返回数据formhash, 文本型
.局部变量 返回登陆状况, 文本型
.局部变量 post地址, 文本型
.局部变量 判断登陆, 文本型
.局部变量 c, 文本型

返回数据formhash = 到文本 (HTTP读文件 (“https://www.daikuanbbs.com/”))
formhash = 文本_取出中间文本 (返回数据formhash, #前面, #后面)
数据 = “formhash=” + formhash + “&referer=https%3A%2F%2Fwww.daikuanbbs.com%2Fhome.php%3Fmod%3Dspacecp%26ac%3Dusergroup&loginfield=username&username=” + 编辑框1.内容 + “&password=” + 编辑框2.内容 + “&questionid=0&answer=”
post地址 = “https://www.daikuanbbs.com/member.php?mod=logging&action=login&loginsubmit=yes&loginhash=LjI88&inajax=1”
返回登陆状况 = 编码_utf8到gb2312 (到文本 (网页_访问 (post地址, 1, 数据, , c)))
调试输出 (返回登陆状况)
.判断开始 (寻找文本 (返回登陆状况, “欢迎您回来”, , 假) > 2)
    信息框 (“登陆成功!”, 0, , )
    分组框1.标题 = “成功登陆:”
    返回数据formhash = 到文本 (HTTP读文件 (“https://www.daikuanbbs.com/”))
    formhash = 文本_取出中间文本 (返回数据formhash, #前面, #后面)
.默认
    信息框 (“登陆异常!”, 0, , )
    分组框1.标题 = “登陆异常:”
.判断结束
调试输出 (c)

调试输出 (formhash)

.子程序 _图片框1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

打开指定网址 (“http://www.xkrj5.com”)

.子程序 _按钮2_被单击
.局部变量 地址, 文本型
.局部变量 消息, 文本型
.局部变量 返回123, 文本型

地址 = “https://www.daikuanbbs.com/home.php?mod=spacecp&ac=pm&op=send&touid=” + 编辑框4.内容 + “”
消息 = “referer=https%3A%2F%2Fwww.daikuanbbs.com%2F.%2F&pmsubmit=true&formhash=” + formhash + “&message=” + 编码_URL编码 (编辑框3.内容, 真, 真) + “&pmsubmit_btn=%3CSTRONG%3E%E5%8F%91%E9%80%81%3C%2FSTRONG%3E”
返回123 = 编码_utf8到gb2312 (到文本 (网页_访问 (地址, 1, 消息)))
信息框 (“已发送数据包,请刷新网页”, 0, , )
[/ecode]
常量和全局变量:
[ecode=1].版本 2

.常量 前面, "<文本长度: 23>"
.常量 后面, "<文本长度: 4>"
[/ecode]
[ecode=1].版本 2

.全局变量 formhash, 文本型
[/ecode]
说明,反正实现方法很简单,需要四个编辑框和两个按钮,即可实现易语言dZ3.4程序版本的登陆发私信功能。
dZ3.4软件成品界面截图:
QQ截图20200121185014.png
模块和源码已经压缩好了,大家在帖子最底部可直接下载。
2222.png
精易抓包工具截图:

抓包

抓包

说明点二:
还有需要注意的一点是,我们发送的文本消息必须要进行URL转码,且不能转码字母和数字,编码的格式必须得是UTF8才可以哦!我们可以用精易模块的“编码_URL编码()”命令实现。
源码和模块下载:
贴吧私信.zip
附件大小:1008.86 KB
下载次数:11




上一篇:易语言随机修改快手md5工具,附源码
下一篇:易语言获取QQ群好友列表,附bkn算法源码
回复

使用道具 举报

 楼主| 发表于 2020-1-21 19:17:20 | 显示全部楼层
如果这篇帖子的内容帮助到了你,希望给个评分,谢谢!!!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-3 05:31 , Processed in 0.159497 second(s), 31 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表