星空软件

 找回密码
 立即注册

易语言随机修改快手md5工具,附源码

发表于 2020-1-19 15:20:53 | 显示全部楼层 |阅读模式
按键精灵
工具(脚本)名称: 随机修改快手Md5
工具(脚本)大小: 37 KB
开发平台: 易语言
工具(脚本)类型: 其他
功能简介: 快手通过对比平台内的视频MD5值来分辨视频的原创,和唯一性,有些用户喜欢把别人的视频直接保存去水印然后发布到自己的快手,其实这样做是不对的,因为你已经违规抄袭别人的原创作品了
快手通过对比平台内的视频MD5值来分辨视频的原创和唯一性,有些用户喜欢把别人的视频直接保存去水印然后发布到自己的快手,其实这样做是不对的,因为你这样做是直接的抄袭了别人的作品,显然已经违规了,如何把别人的原创作品再变成自己的原创作用呢?可以修改视频的MD5值来进行实现。我们借助易语言来给大家写一款快手视频MD5修改工具,大家可以拿去用,我们会提供这款工具的开发教程和开发思路,也会提供源码给大家哦!
需要的工具和原料:
1、易语言
2、一个MP4格式视频
开发思路:
就是读取原视频的MD5值,然后通过程序命令给原视频加入一些字符串,来实现修改MD5的效果。
开发步骤:
1、我们打开易语言,然后新建窗口,然后再窗口里面拖入三个编辑框和一个按钮还有一个拖放组件。
1.png
2、然后我们双击窗口进入到“_启动窗口”代码编辑处,键入“拖放对象1.注册拖放控件 (取窗口句柄 ())”,需要把拖放组件进行注册一下才可以,不然你没办法吧外部文件拖放到程序里面。
weq.png
3、进入启动窗口界面,然后单击“拖放对象”,然后在组件的事件选择框哪里选择“得到文件”。
2233.png
4、然后在得到文件的事件子程序哪里键入“编辑框1.内容 = 接收到的文件路径”,意思就是说把拖放的外部文件路径值返回到编辑框1的内容里面,在键入“编辑框2.内容 = 取数据摘要 (读入文件 (编辑框1.内容))”,意思是获取文件的md5值,然后把值返回到编辑框2的内容里面。
231312zhaiyao.png
5、再次进入到启动窗口界面,我们双击按钮1进入按钮1被单击的事件编辑框,键入“文件 = 读入文件 (编辑框1.内容) + 到字节集 (取随机数 (0, 9999))”,意思是读入编辑框1指定的文件,把读入的字节集数据返回到变量文件里面,然后再给字节集“文件”变量加入一个随机数,再键入“写到文件 (取运行目录 () + “/md5.mp4”, 文件)”,意思是把字节集变量文件写到程序的运行目录里面,再次键入“编辑框3.内容 = 取数据摘要 (读入文件 (取运行目录 () + “/md5.mp4”))”,意思是在编辑框3里面读入被上一个命令导出的文件MD5值,这样就实现了修改视频的MD5值。
xiugai.png
6、通过以上的代码段我们就可以实现修改视频MD5值,很简单,也很实用,大家不妨来试一下吧。

修改

修改

案例代码:[ecode=4].版本 2
.支持库 dp1
.支持库 edroptarget

.程序集 窗口程序集_启动窗口

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

编辑框1.内容 = 接收到的文件路径
编辑框2.内容 = 取数据摘要 (读入文件 (编辑框1.内容))

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (取窗口句柄 ())


.子程序 _按钮1_被单击
.局部变量 文件, 字节集

文件 = 读入文件 (编辑框1.内容) + 到字节集 (取随机数 (0, 9999))
写到文件 (取运行目录 () + “/md5.mp4”, 文件)
编辑框3.内容 = 取数据摘要 (读入文件 (取运行目录 () + “/md5.mp4”))

[/ecode]
文件下载:(程序和源码)
修改视频md5工具.zip
附件大小:712.18 KB
下载次数:38




上一篇:易语言快手去水印工具,附源码和视频解析原理
下一篇:易语言Discuz3.4登陆加发私信工具,附源码
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-5 14:03 , Processed in 0.136687 second(s), 31 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表