星空软件

 找回密码
 立即注册

易语言快手去水印工具,附源码和视频解析原理

发表于 2020-1-19 14:14:05 | 显示全部楼层 |阅读模式
按键精灵
工具(脚本)名称: 易语言开发快手去水印工具
工具(脚本)大小: 23 KB
开发平台: 易语言
工具(脚本)类型: 其他
功能简介: 我们都知道,在快手上面看到自己喜欢的视频,但是没办法保存,而有些视频可以保存不过视频却有水印很难看,怎么办呢?
我们都知道,在快手上面看到自己喜欢的视频,但是没办法保存,而有些视频可以保存不过视频却有水印很难看,怎么办呢?我们今天这篇文章就是利用易语言开发一款快手视频下载+快手去水印的工具,开发起来也是很简单,我们会把工具的开发步骤,开发思路,还有源码都会分享给大家,希望能帮助到大家。
好了,我们就不废话,进入文章主题。
需要的工具和原料:
1、易语言5.8
2、精易模块v8.0
3、gzip.dll
4、Fiddler.exe
开发思路:
其实我们是利用易语言对接第三方的快手视频解析接口进行实现快手视频下载和去水印的效果,“3g.gljlw.com/diy/ttxs_ks.php”,这是一个快手视频解析页面,我们从快手APP复制的视频链接输入到这个页面,然后提交,页面就会自动给你输出视频的解析地址,也就是视频的下载地址,并且是无水印的,很神奇吧,我们的开发思路就是利用易语言对接这个页面的视频解析接口,给我们的程序实现独立的视频下载和去水印功能,但是首先你需要用Fiddler抓包工具抓取到相关的数据提交接口和数据处理对象才可以哦。
QQ截图20200119130121.png
开发步骤:
1、我们分析“3g.gljlw.com/diy/ttxs_ks.php”这个页面的数据提交方式,发现是get方式的,所以我们先用Fiddler进行抓包获取get的信息。
QQ截图20200119130303.png
2、获取到抓包信息后我们就对数据进行分析,然后找出get提交的数据,然后对数据进行分析处理。
QQ截图20200119130838.png
4、分析得出,get提交数据里面有个“R”参数和“S”参数,而且这两个参数的值都是随机变化的,我们去视频提交页面查看了一下参数相关JS代码发现两个值都是随机生成的,而生成随机值用的JS代码我们已经附加到源码里面了,大家下去了可以看下。
2.png
5、解决了视频解析原理后我们直接把页面的GET接口和数据处理方式对接到我们的易语言程序里面。
2.png
6、我们需要把JS代码加入到我们易语言程序的长文本常量里面,方便调用,因为易语言是可以直接运行相关的JS代码的,所以直接把对方的JS代码导入到我们的程序里面就可以了。
QQ截图20200119131819.png
7、然后再我们的程序里面加入一个“脚本组件”,完了我们双击“按钮”开始编辑代码,为了节约大家的时间,大家可以直接把我们提供的案例代码粘贴到你的代码框里面,前提你要保证你程序的所有控件和我提供的程序所有控件数量和属性必须要一致,不然会出错。[ecode=1].版本 2
.支持库 script

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 r, 文本型
.局部变量 s, 文本型
.局部变量 parseTempStr, 文本型
.局部变量 GET, 文本型
.局部变量 解析地址, 文本型
.局部变量 返回数据, 文本型

脚本组件1.执行 (#JS)
r = 脚本组件1.运行 (“csr”, )
parseTempStr = 编辑框1.内容 + “@&^” + r
s = 脚本组件1.运行 (“generateStr”, parseTempStr)
GET = “http://3g.gljlw.com/diy/ttxs_ks.php?url=https%3A//” + 编辑框1.内容 + “&r=” + r + “&s=” + s
返回数据 = 编码_utf8到gb2312 (到文本 (网页_GZIP解压 (网页_访问_对象 (GET, 0, , , , #协议头, #协议头, , , , , 5000, , ))))
解析地址 = 文本_取出中间文本 (返回数据, #前面, #后面)
编辑框2.内容 = 解析地址[/ecode]
8、我们需要在程序里面再加入三个长文本常量“.常量 前面, "<文本长度: 122>" .常量 后面, "<文本长度: 39>" .常量 协议头, "<文本长度: 425>”,关于这些常量的作用就是为了程序使用,我们在帖子下方会给大家讲每个常量的作用,常量内容大家请在小编提供的案例源码里面找,然后加入到你的源码里面即可。
3.png
8、最后程序的运行结果是可以直接获取到视频的解析地址。
3.png
程序代码和常量讲解:
.常量 前面, "<文本长度: 122>"
.常量 后面, "<文本长度: 39>"
讲解:因为网页访问命令返回的get数据是源码形式的,所以我们需要利用“文本_取出中间文本 (#前面, #后面)”命令进行替换源码里面前面和后面的特征字符才能截取到最终的视频地址。
.常量 协议头, "<文本长度: 425>"
讲解:这个常量包含的是get提交用的协议头数据,我们用Fiddler抓包即可获取,我们需要把协议头加入到常量里面,供网页_访问里面使用。

协议头

协议头

脚本组件1.执行 (#JS)
r = 脚本组件1.运行 (“csr”, )
讲解:脚本组件1.执行 (#JS)意思是执行#js常量包含的JS代码, r = 脚本组件1.运行 (“csr”, )意思是运行js代码里面的csr对象(函数),然后把执行结果返回到r变量里面。
网页_GZIP解压()
讲解:因为有些GET数据是通过GZIP压缩形式返回的,所以我们需要利用这个命令来进行把GZIP压缩的数据给解压出来,但是要用这个命令的话需要“gzip.dll”文件才可以,大家可以在帖子下方进行下载使用,这个“gzip.dll”文件必须要和程序在同一个目录下才行,不然会出错。
文件下载:
快手去水印.zip
附件大小:1.72 MB
下载次数:47




上一篇:关于怎么用按键精灵制作抖音自动私信脚本
下一篇:易语言随机修改快手md5工具,附源码
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-5-29 20:57 , Processed in 0.146521 second(s), 31 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表