星空软件

 找回密码
 立即注册

易语言画板组建实现图片加水印并导出到本地

发表于 2020-1-12 15:10:53 | 显示全部楼层 |阅读模式
易语言
工具(脚本)名称: 易语言水印工具
工具(脚本)大小: 24 KB
开发平台: 易语言
工具(脚本)类型: 生活工作
功能简介: 易语言相比大家都很熟悉吧,是国内一款面向对象的中文编程工具,所有功能代码都是通过中文命令进行编辑的
易语言相比大家都很熟悉吧,是国内一款面向对象的中文编程工具,所有功能代码都是通过中文命令进行编辑的,下面小编将给大家详细的介绍一下易语言。
易语言详细介绍:引用百科的文献
易语言(EPL)是一门以中文作为程序代码编程语言,其以“易”著称,创始人为吴涛。易语言早期版本的名字为E语言。其最早的版本的发布可追溯至2000年9月11日。创造易语言的初衷是进行用中文来编写程序的实践,方便中国人以中国人的思维编写程序,并不用再去学习西方思维。易语言的诞生极大的降低了编程的门槛和学习的难度。从2000年以来,易语言已经发展到一定的规模,功能上、用户数量上都十分可观。
如果是学过易语言编程开发的朋友读到下面讲的知识内容很轻松就能消化掉,如果你没有学过易语言开发的话想要熟悉的了解以下所有的知识点难度还是比较大的,但是小编今天会分成几个开发步骤来详细的给大家讲解,并且还是给大家免费提供这款易语言开发的水印工具源码。
如何用易语言的画板组建开发出一款水印工具呢?请看步骤:
1、下载易语言,完了安装到电脑,并且打开易语言。(下载易语言请去这里:解决易语言:系统执行文件被非法篡改,请检查病毒并重新..
2、完了我们在易语言菜单栏依次点击程序->新建->windows程序,看下图操作。
QQ截图20200112140232.png
3、新建windows程序窗口后,我们在右侧的组建栏选择“画板”组建,然后拖动到程序窗口区域里面,看下图。
2.png
4、完了我们再多余的程序窗口添加两个按钮,“读入图片”按钮和“保存图片”按钮,再添加一个文本编辑框和两个通用对话框组建(通用对话框1类型设置为保存文件,通过对话框2类型设置为打开文件)。
QQ截图20200112141213.png
5、双击“导入图片”按钮开始编写代码,下面是小编提供的完整代码参考,你可以直接复制拷贝到你的代码编辑框里面,前提:上文讲到的所有空间都要设置要,应用到才可以,不然代码会出错。
完整案例代码参考:
  1. .版本 2

  2. .程序集 窗口程序集_启动窗口
  3. .子程序 _按钮1_被单击
  4. .局部变量 图片, 字节集
  5. .局部变量 图片号, 整数型
  6. .局部变量 图片路径, 文本型
  7. 通用对话框2.打开 ()   ' 讲的意思是打开激活通用对话框2组件。
  8. 图片路径 = 通用对话框2.文件名   ' 意思是把通用对话框2打开的文件路径传值到图片路径变量里面。
  9. 图片 = 读入文件 (图片路径)   '这个图片类型需要为字节集,字节集内容需要用读入文件函数进行读入。
  10. 图片号 = 载入图片 (图片)   '图片号必须为整数型,通过载入图片获取图片号。
  11. 画板1.画图片 (图片号, 0, 0, , , )   '在画板1里面画入图片
  12. 画板1.置写出位置 (100, 200)   '设置画板1的文本写出位置
  13. 画板1.字体.字体大小 = 20   '设置画板文本大小
  14. 画板1.文本颜色 = #红色   '设置画板文本颜色
复制代码

程序执行效果演示:
一:我们点击“读入图片”按钮,然后选择电脑里面的某个图片。
2.png
二:选择完以后,画板就会显示被选择的图片和编辑框2里面的文字,文字水印效果已经显现了。
2.png
三:完了我们再点击“保存图片”按钮,然后选择保存的文件路径,并在对话框的文件名里面写入“保存.png”,然后点击保存按钮。
2.png
四:点击保存按钮后,我们去看下电脑本地桌面,果然,图片已经成功导出到本地了。

保存1

保存1

易语言画板水印工具(附源码)下载:
易语言水印工具.rar
附件大小:501.65 KB
下载次数:4




上一篇:WebBrowser1.HtmlInput 实现浏览器文本自动填写与点击
下一篇:关于怎么用按键精灵制作抖音自动私信脚本
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

sitemap|星空软件

GMT+8, 2020-6-3 05:42 , Processed in 0.162436 second(s), 31 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表